Search outage on EU cluster
Incident Report for Cludo
Postmortem

We released new development related to Actionable Recommendations into our backend API that introduced an unexpected amount of pressure to our search cluster. This degraded performance combined with facing peak service times was enough to overwhelm our search service. After identifying the issue, we rolled back to a previous state and have resolved the underlying issue.

Since the issue was resolved, we’ve introduced alerts that will early detect problems of this nature as well as tooling for more graceful resolution.

Posted Oct 11, 2023 - 17:45 CEST

Resolved
This incident has been resolved.
Posted Oct 05, 2023 - 11:05 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 05, 2023 - 10:50 CEST
Investigating
We are currently investigating this issue.
Posted Oct 05, 2023 - 10:35 CEST
This incident affected: Search API EU.