Intelligent Autocomplete issues
Incident Report for Cludo
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 28, 2019 - 12:50 UTC
Investigating
We are currently experiencing issues affecting Intelligent Autocomplete. We're investigating the impact of the outage and working towards resolving the issue.
Posted 4 months ago. Jun 28, 2019 - 12:30 UTC