Analytics missing since Friday (EU only)

Incident Report for Cludo

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 22:14 CET

Monitoring

We have identified the issue affecting EU analytics and applied a fix. Analytics data is currently being rebuilt and processed.

We are monitoring progress closely and expect analytics to be fully back to normal within the next few hours.

We will provide another update once fully resolved.
Posted Mar 23, 2026 - 16:32 CET

Identified

We are currently investigating an issue affecting analytics data for all customers hosted on our EU cluster. Data from Friday through today is currently missing. Search functionality is not affected and continues to operate as normal.

Our team is actively working on resolving the issue, and we expect a resolution by the end of the day. Once resolved, we anticipate that all missing analytics data will be fully recovered for the affected period.

Please keep an eye on this page or subscribe to updates to be notified as soon as the issue has been resolved.
Posted Mar 23, 2026 - 12:13 CET
This incident affected: Search API EU.