Degraded Search Performance – EU Region

Incident Report for Cludo

Resolved

The misconfiguration has been reverted and all systems are operating normally. US was unaffected throughout the incident.
Posted Apr 20, 2026 - 15:20 CEST

Identified

Search is operational but EU users may experience degraded search result quality and slower response times. US is unaffected.
We have identified the root cause in the EU infrastructure. A fix is being applied. We will provide a further update once the issue is resolved.
Posted Apr 20, 2026 - 15:08 CEST
This incident affected: Search API EU and Cludo AI EU.