Issues with search and MyCludo (US)
Incident Report for Cludo
Postmortem

We were experiencing degraded performance on our US search cluster due to an infrastructure failure. This resulted in slow response times for both search and MyCludo. All systems are now operational, and our development team will of course dedicate time to further investigate and analyze the issue to take any possible preventive measures for the future.

We sincerely apologize for the inconvenience that this must have caused for you and your visitors.

Posted Apr 12, 2024 - 17:45 CEST

Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 17:41 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2024 - 17:34 CEST
Update
It has been revealed that search performance is affected as well. We are continuing to investigate the issue.
Posted Apr 12, 2024 - 16:53 CEST
Investigating
We are currently experiencing issues logging into MyCludo on our US cluster. Some requests fail while others are very slow. We are investigating the issue and will continue to update our status page.
Posted Apr 12, 2024 - 16:46 CEST
This incident affected: MyCludo and Search API US.