Search down or very slow in EU

Incident Report for Cludo

Resolved

We had a brief period of the search being unresponsive or slow. The issue was quickly resolved and will have had a minimal impact on search performance.
Posted Oct 24, 2025 - 10:35 CEST

Monitoring

We have been experiencing brief outages and slow responses in EU search from around 10:18 CEST to 10:21 CEST. We were able to quickly recover from this and are monitoring the system performance.
Posted Oct 24, 2025 - 10:23 CEST
This incident affected: Search API EU.