Our domain customer.cludo.com is currently down

Incident Report for Cludo

Resolved

The earlier issue causing increased latency and preventing search scripts from loading has been fully resolved. All services are now operating normally.

Thank you for your patience while we worked to restore functionality.
Posted Sep 17, 2025 - 15:17 CEST

Identified

We are experiencing an issue that is causing increased latency in search and preventing our search scripts from loading. Our team is actively investigating and working to restore full functionality as quickly as possible. We apologize for the disruption and appreciate your patience.
Posted Sep 17, 2025 - 14:53 CEST
This incident affected: Search API EU and Search API US.