Network performance issues caused by Cloudflare
Incident Report for Cludo
Resolved
We have deployed a change that makes Cludo not rely on Cloudflare. Other sites that utilize Cloudflare for their own needs would still be affected.
Posted 4 months ago. Jul 02, 2019 - 14:12 UTC
Identified
Cloudflare is currently experiencing network performance issues, causing customer websites to experience 502 errors. CloudFlare is the CDN Cludo uses for getting resources for the Cludo script and all files that come from http://customer.cludo.com/.

Searches implemented using API are not affected.
Posted 4 months ago. Jul 02, 2019 - 14:00 UTC
This incident affected: Search API EU and Search API US.