Degraded Performance
Incident Report for Cludo
Resolved
This incident has been resolved.
Posted Sep 16, 2024 - 12:13 CEST
Identified
We are currently experiencing degraded performance across our platform. This is due to a global issue with Cloudflare, which is impacting several services worldwide, including ours.
Posted Sep 16, 2024 - 11:00 CEST
This incident affected: Search API EU and Search API US.