Degraded performance: Cludo Search

Incident Report for Cludo

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 10:32 CEST

Investigating

We're currently experiencing an issue affecting search response times and are working to resolve it as quickly as possible. We apologize for the inconvenience.
Posted Jun 01, 2026 - 10:03 CEST
This incident affected: Search API EU.