We’ve verified that the issue has been resolved across major DNS providers. For affected users, access will be fully restored as their DNS provider refreshes its cached records.
Some DNS providers may take up to 48 hours to refresh their cache. During this period, a small number of users may still experience issues. If you continue to experience problems after this time, please contact us at support@cludo.com and we’ll be happy to assist.
Posted Feb 11, 2026 - 18:02 CET
Monitoring
The issue was caused by a change in DNS settings that made our services unreachable for some users. These settings were already fixed, but some internet providers have cached the bad settings, while others are already back to normal.
We're currently working on speeding up this process to restore access for all our customers who are still affected by this.
Posted Feb 11, 2026 - 13:02 CET
Investigating
We are aware that some customers may be experiencing issues with search and/or accessing MyCludo. Our team is actively investigating and working to identify the root cause. Further updates will be shared as soon as possible.
Posted Feb 11, 2026 - 12:33 CET
This incident affected: MyCludo and Search API EU.