Autocomplete issues
Incident Report for Cludo
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 05, 2019 - 13:57 UTC
Monitoring
Issue has been identified and fixed
Posted 7 months ago. Apr 05, 2019 - 13:33 UTC
Investigating
We are currently investigating this issue.
Posted 7 months ago. Apr 05, 2019 - 13:06 UTC
This incident affected: Search API EU.