Degraded performance: Cludo Search

Incident Report for Cludo

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 17:15 CET

Update

This issue has been mitigated by our team. We will continue to investigate the root causes behind it to avoid it from reoccurring.
Once again, we apologize for any inconvenience this must have caused.
Posted Nov 03, 2025 - 17:05 CET

Investigating

We are currently experiencing an issue that is causing longer latency and search errors in our search.
We apologize for any inconvenience that this might cause while we investigate and resolve this.
Posted Nov 03, 2025 - 16:53 CET
This incident affected: Search API EU.